This article explains how to change the LED light pattern on your Sidekick. This includes how to update the current pattern(s) on your Sidekick, how to adjust existing patterns to function with Sidekick, and how to save/use more than one pattern at once.


HOW TO UPDATE THE CURRENT PATTERN


1.

First, download the latest version of BlinkinLabs Pattern Paint software onto your Windows based computer. You can find the latest version Here!


The version referenced in this tutorial is 2.4.


2.

Once you've downloaded Pattern paint, disconnect your LED USB and LED controller from your Sidekick and plug the USB into your computer with Pattern Paint.



3.

Open up Pattern Paint. 


4.

Make sure the firmware is 100% up to date. You can update the Firmware by going to Tools and select "Restore Firmware":



Now we're ready to upload a pattern!


5.

Upload a pattern that you have saved to your computer, by going to File > Open > Scrolling Pattern and then search for the pattern:



You can find available patterns on the Owners page if you want to select an aesthetic similar to those used on your INFINITE or VENTURE booth running PBU (see below for information on how to adjust it for Sidekick). Or you can even make your own!


6.

Now that you've loaded a pattern, disconnect the LED USB and Controller, and reattach them to your booth.


Congratulations on your awesome new sidekick running pattern!




HOW TO ADJUST EXISTING PATTERNS TO BE USED ON SIDEKICK


We're using the "ALL BOOTHS - Rainbow" (available on our Owners page) for the example below:



1.

You should set the height to "29" for the Sidekick, as that is the length of the Sidekick LED strand. 


(Sidenote - The LED height for the VENTURE is 150 and for the INFINITE is 475).


To set the height, go to Tools > Scene Configuration, then set the height to "29" and click "OK."


It will ask you about resizing, then "Accept" to finish!



            

2.

Now, save the pattern to your led strip by going to Tools > Save to Blinky:





SAVING/USING MORE THAN ONE PATTERN


If you have more than one pattern loaded in the tool tray on the left, multiple patterns will be saved to the control chip at the same time. The controller will then cycle through the patterns.


To add or remove patterns, there is a "plus" and a "minus" button directly under the file and edit menu: